İçeriğe geç

Phalcon Framework Kurulumu

CentOS 6.8 Üzerinde Kurulum Yapılmıştır.cPanel İle Problemsiz Koşmaktadır.

Sunucumuza SSH İle Login Oluyoruz.

yum install php-devel pcre-devel gcc make

git clone –depth=1 git://github.com/phalcon/cphalcon.git

cd cphalcon/build

./install

Kurulum Hatasız Tamamlanırsa php.ini Ye extension Ekliyoruz.

extension=phalcon.so

Bu Kadar Hata İle Karşılaşırsak.

Build Dizini İçinden 32 veya 64 Kaç Bit Sisteme Kuracaksak Dizine Geçiyoruz

export CFLAGS=”-O2 –fvisibility=hidden”

./configure –enable-phalcon

Gerisi Derle ve Derlediğini Kur Şeklinde.

İyi Çalışmalar Dilerim.

Tarih:CentOScPanel

2 Yorum

  1. izzet aslan izzet aslan

    Merhaba

    Yazınız için teşekkürler,,

    fakat ben şöyle bir hata aldım yardımcı olursanız sevirim.

    php 5.4 is no longer suportted

    sanal sunucu kullanıyorum ve üzerinde centos 7 plesk onyx kurulu

    teşekkürler

    • MelihUnutmaz MelihUnutmaz

      Merhaba Standartta Plesk PHP 5.4 Üzerinde Çalışıyor Üst Sürüme Çekebilirsiniz Hatayı Aşmak İçin Phalcon Sürümünüz Bu PHP Sürümünü Desteklemiyor Muhtemelen.

      Ancak Git İle Kolayca Kurabilirsiniz.

      İyi Çalışmalar.

Bir Cevap Yazın

E-posta hesabınız yayımlanmayacak. Gerekli alanlar * ile işaretlenmişlerdir